Wheel installs require setuptools >= 0.8 for dist-info support. | Sam & Max: Python, Django, Git et du cul

Wheel installs require setuptools >= 0.8 for dist-info support.

Je ne sais pas pourquoi, mais une fois j’ai eu cette erreur en essayant d’installer un truc avec pip.

La solution est de lancer :

sudo pip install setuptools --no-use-wheel --upgrade

Et on peut réutiliser pip sans problème.

Zarb.

  2 comments for “Wheel installs require setuptools >= 0.8 for dist-info support.

  1. frnx
    22/01/2014 at 20:23

    Mais setuptools, c’est un gros hack et ça fait plein de trucs zarb, non? Perso, après avoir subi le genre de bug quantique qui arrive une fois sur deux au hasard quand tu installes ton paquet, je suis repassé à distutils pour les paquets que je fais moi-même. Moins de features, mais moins de prise de tête!

  2. 22/01/2014 at 23:43

    Mwarf, je crois que c’est parce qu’à partir de la version 1.5 de pip ça utilise l’archive “wheel” qui nécessite la version 8 ou plus de “setup tools version”. Et tu devais avoir une version < 8. Du coup la commande que tu fournis omet wheel et après ça roule-pun intended (woho, il est tard et j'ai pas bu que du perrier avec la raclette ^^').

Leave a Reply

Your email address will not be published. Required fields are marked *